GitHub Advisoryadvisory · Maven

GHSA-p6xc-xr62-6r2g Apache Log4j2 vulnerable to Improper Input Validation and Uncontrolled Recursion

HIGH Published 2021-12-18 Modified 2026-06-09 Official page ↗
Aliases
CVE-2021-45105
Ecosystem
Maven
Packages
org.apache.logging.log4j:log4j-core, org.ops4j.pax.logging:pax-logging-log4j2
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
Weaknesses
CWE-20, CWE-674
Reviewed
2021-12-18

Affected packages

• Maven org.apache.logging.log4j:log4j-core: >= 2.4.0, < 2.12.3 → fixed in 2.12.3 • Maven org.apache.logging.log4j:log4j-core: >= 2.13.0, < 2.17.0 → fixed in 2.17.0 • Maven org.apache.logging.log4j:log4j-core: < 2.3.1 → fixed in 2.3.1 • Maven org.ops4j.pax.logging:pax-logging-log4j2: >= 1.8.0, < 1.9.2 → fixed in 1.9.2 • Maven org.ops4j.pax.logging:pax-logging-log4j2: >= 1.10.0, < 1.10.9 → fixed in 1.10.9 • Maven org.ops4j.pax.logging:pax-logging-log4j2: >= 1.11.0, < 1.11.12 → fixed in 1.11.12 • Maven org.ops4j.pax.logging:pax-logging-log4j2: >= 2.0.0, < 2.0.13 → fixed in 2.0.13

Description

Apache Log4j2 versions 2.0-alpha1 through 2.16.0 (excluding 2.12.3) did not protect from uncontrolled recursion from self-referential lookups. This allows an attacker with control over Thread Context Map data to cause a denial of service when a crafted string is interpreted. This issue was fixed in Log4j 2.17.0 and 2.12.3. Affected packages Only the `org.apache.logging.log4j:log4j-core` package is directly affected by this vulnerability. The `org.apache.logging.log4j:log4j-api` should be kept at the same version as the `org.apache.logging.log4j:log4j-core` package to ensure compatability if in use.

Related

Alias · CVE (1)

  • CVE-2021-45105 Apache Log4j2 versions 2.0-alpha1 through 2.16.0 (excluding 2.12.3 and 2.3.1) did not protect from uncontrolled recursion from… vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-674 Uncontrolled Recursion weakness

References