GitHub Advisoryadvisory · Maven

GHSA-p72w-r6fv-6g5h druid-pac4j, Apache Druid extension, has Padding Oracle vulnerability

LOW Published 2024-09-17 Modified 2025-03-14 Official page ↗
Aliases
CVE-2024-45384
Ecosystem
Maven
Packages
org.apache.druid.extensions:druid-pac4j
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-209, CWE-347
Reviewed
2024-09-17

Affected packages

• Maven org.apache.druid.extensions:druid-pac4j: >= 0.18.0, < 30.0.1 → fixed in 30.0.1

Description

Padding Oracle vulnerability in Apache Druid extension, druid-pac4j. This could allow an attacker to manipulate a pac4j session cookie. This issue affects Apache Druid versions 0.18.0 through 30.0.0. Since the druid-pac4j extension is optional and disabled by default, Druid installations not using the druid-pac4j extension are not affected by this vulnerability. While we are not aware of a way to meaningfully exploit this flaw, we nevertheless recommend upgrading to version 30.0.1 or higher which fixes the issue and ensuring you have a strong druid.auth.pac4j.cookiePassphrase as a precaution.

Related

Alias · CVE (1)

  • CVE-2024-45384 Padding Oracle vulnerability in Apache Druid extension, druid-pac4j. vulnerability

Weakness · CWE (2)

  • CWE-209 Generation of Error Message Containing Sensitive Information weakness
  • CWE-347 Improper Verification of Cryptographic Signature weakness

References