GitHub Advisoryadvisory · Go
GHSA-p744-4q6p-hvc2 Wings vulnerable to escape to host from installation container
CRITICAL
Official page ↗
- Aliases
- CVE-2023-32080
- Ecosystem
- Go
- Packages
- github.com/pterodactyl/wings
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-250
- Reviewed
- 2023-05-11
Affected packages
• Go github.com/pterodactyl/wings: < 1.7.5 → fixed in 1.7.5
• Go github.com/pterodactyl/wings: >= 1.11.0, < 1.11.6 → fixed in 1.11.6
Description
Impact
This vulnerability impacts anyone running the affected versions of Wings. This vulnerability can be used to gain access to the host system running Wings if a user is able to modify an server's install script or the install script executes code supplied by the user (either through environment variables, or commands that execute commands based off of user data).
Patches
This vulnerability has been resolved in version `v1.11.6` of Wings, and has been back-ported to the 1.7 release series in `v1.7.5`.
Anyone running `v1.11.x` should upgrade to `v1.11.6` and anyone running `v1.7.x` should upgrade to `v1.7.5`.
Workarounds
Running Wings with a rootless container runtime may mitigate the severity of any attacks, however the majority of users are using container runtimes that run as root as per our documentation.
SELinux may prevent attackers from performing certain operations against the host system, however privileged containers have a lot of freedom even on systems with SELinux enabled.
TL;DR: None at this time.
Extra details
It should be noted that this was a known attack vector, for attackers to easily exploit this attack it would require compromising an administrator account on a Panel. However, certain eggs (the data structure that holds the install scripts that get passed to Wings) have an issue where they are unknowingly executing shell commands with escalated privileges provided by untrusted user data.
Related
Alias · CVE (1)
- CVE-2023-32080 Wings is the server control plane for Pterodactyl Panel. vulnerability
Weakness · CWE (1)
- CWE-250 Execution with Unnecessary Privileges weakness
References
- https://github.com/pterodactyl/wings/security/advisories/GHSA-p744-4q6p-hvc2 web
- https://nvd.nist.gov/vuln/detail/CVE-2023-32080 advisory
- https://github.com/pterodactyl/wings package
- https://github.com/pterodactyl/wings/releases/tag/v1.11.6 web
- https://github.com/pterodactyl/wings/releases/tag/v1.17.5 web
- https://github.com/pterodactyl/wings/releases/tag/v1.7.5 web