GitHub Advisoryadvisory · Packagist
GHSA-p746-qw73-qmmx Magento XML Injection vulnerability in the Widgets Module
CRITICAL
Official page ↗
- Aliases
- CVE-2021-36033
- Ecosystem
- Packagist
- Packages
- magento/project-community-edition, magento/community-edition
- Severity
- Critical
- Weaknesses
- CWE-91
- Reviewed
- 2025-11-06
Affected packages
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
• Packagist magento/community-edition: < 2.3.7-p1 → fixed in 2.3.7-p1
• Packagist magento/community-edition: 2.3.7 (no fix yet)
• Packagist magento/community-edition: >= 2.4.2-p1, < 2.4.2-p2 → fixed in 2.4.2-p2
• Packagist magento/community-edition: 2.4.2 (no fix yet)
Description
Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an XML Injection vulnerability in the Widgets Module. An attacker with admin privileges can trigger a specially crafted script to achieve remote code execution.
Related
Alias · CVE (1)
- CVE-2021-36033 Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an XML Injection… vulnerability
Weakness · CWE (1)
- CWE-91 XML Injection weakness