GitHub Advisoryadvisory · PyPI

GHSA-p75j-wc34-527c Exposure of Sensitive Information to an Unauthorized Actor in ansible

HIGH Published 2021-10-12 Modified 2024-11-18 Official page ↗
Aliases
CVE-2019-10217
Ecosystem
PyPI
Packages
ansible
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-200
Reviewed
2021-10-08

Affected packages

• PyPI ansible: >= 2.8.0a1, < 2.8.4 → fixed in 2.8.4

Description

A flaw was found in ansible 2.8.0 before 2.8.4. Fields managing sensitive data should be set as such by no_log feature. Some of these fields in GCP modules are not set properly. service_account_contents() which is common class for all gcp modules is not setting no_log to True. Any sensitive data managed by that function would be leak as an output when running ansible playbooks.

Related

Alias · CVE (1)

  • CVE-2019-10217 A flaw was found in ansible 2.8.0 before 2.8.4. vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References