GitHub Advisoryadvisory · Maven

GHSA-p76j-5v6v-6c22 Apache NiFi JMS Deserialization issue

HIGH Published 2022-05-14 Modified 2022-11-01 Official page ↗
Aliases
CVE-2018-1310
Ecosystem
Maven
Packages
org.apache.nifi:nifi
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-502
Reviewed
2022-11-01

Affected packages

• Maven org.apache.nifi:nifi: < 1.6.0 → fixed in 1.6.0

Description

Apache NiFi JMS Deserialization issue because of ActiveMQ client vulnerability. Malicious JMS content could cause denial of service. See ActiveMQ CVE-2015-5254 announcement for more information. The fix to upgrade the activemq-client library to 5.15.3 was applied on the Apache NiFi 1.6.0 release. Users running a prior 1.x release should upgrade to the appropriate release.

Related

Alias · CVE (1)

  • CVE-2018-1310 Apache NiFi JMS Deserialization issue because of ActiveMQ client vulnerability. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References