GitHub Advisoryadvisory · Packagist

GHSA-p783-gj6m-9r88 Magento 2 Community Edition RCE Vulnerability

HIGH Published 2022-05-24 Modified 2024-02-12 Official page ↗
Aliases
CVE-2019-8150
Ecosystem
Packagist
Packages
magento/community-edition
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Reviewed
2023-07-18

Affected packages

• Packagist magento/community-edition: >= 2.2.0, < 2.2.10 → fixed in 2.2.10 • Packagist magento/community-edition: >= 2.3.0, < 2.3.2-p2 → fixed in 2.3.2-p2

Description

A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with privileges to manipulate layouts and images can insert a malicious payload into the page layout. As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.

Related

Alias · CVE (1)

  • CVE-2019-8150 A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. vulnerability

References