GitHub Advisoryadvisory · npm
GHSA-p788-rj37-357w Insecure Defaults Leads to Potential MITM in ezseed-transmission
MEDIUM
Official page ↗
- Aliases
- CVE-2016-1000224
- Ecosystem
- npm
- Packages
- ezseed-transmission
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-295, CWE-300
- Reviewed
- 2020-08-31
Affected packages
• npm ezseed-transmission: >= 0.0.10, < 0.0.15 → fixed in 0.0.15
Description
Affected versions of `ezseed-transmission` download and run a script over an HTTP connection.
An attacker in a privileged network position could launch a Man-in-the-Middle attack and intercept the script, replacing it with malicious code, completely compromising the system running `ezseed-transmission`.
Recommendation
Update to version 0.0.15 or later.