GitHub Advisoryadvisory · RubyGems

GHSA-p7f2-rr42-m9xm RubyGems Improper Input Validation vulnerability

HIGH Published 2022-05-14 Modified 2023-03-10 Official page ↗
Aliases
CVE-2017-0900
Ecosystem
RubyGems
Packages
rubygems-update
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20
Reviewed
2023-03-10

Affected packages

• RubyGems rubygems-update: < 2.6.13 → fixed in 2.6.13

Description

RubyGems versions 2.6.12 and earlier are vulnerable to maliciously crafted gem specifications that cause a denial of service attack against RubyGems clients who have issued a `query` command.

Related

Alias · CVE (1)

  • CVE-2017-0900 RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications to cause a denial of service attack against… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References