GitHub Advisoryadvisory · Packagist

GHSA-p7v9-gjrh-563x Moodle XSS Vulnerability

HIGH Published 2022-05-13 Modified 2023-10-06 Official page ↗
Aliases
CVE-2018-10891
Ecosystem
Packagist
Packages
moodle/moodle
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-20
Reviewed
2023-07-20

Affected packages

• Packagist moodle/moodle: >= 3.5.0, < 3.5.1 → fixed in 3.5.1 • Packagist moodle/moodle: >= 3.4.0, < 3.4.4 → fixed in 3.4.4 • Packagist moodle/moodle: >= 3.3.0, < 3.3.7 → fixed in 3.3.7 • Packagist moodle/moodle: >= 3.2.0, < 3.2.10 → fixed in 3.2.10 • Packagist moodle/moodle: >= 3.1.0, < 3.1.13 → fixed in 3.1.13

Description

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.

Related

Alias · CVE (1)

  • CVE-2018-10891 A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References