GitHub Advisoryadvisory · Maven
GHSA-p7w2-784m-qpq9 Apache Ambari Expression Language Injection vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2022-45855
- Ecosystem
- Maven
- Packages
- org.apache.ambari:ambari
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-917
- Reviewed
- 2023-07-12
Affected packages
• Maven org.apache.ambari:ambari: >= 2.7.0, < 2.7.7 → fixed in 2.7.7
Description
SpringEL injection in the metrics source in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary code remotely. Users are recommended to upgrade to 2.7.7.
Related
Alias · CVE (1)
- CVE-2022-45855 SpringEL injection in the metrics source in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary… vulnerability
Weakness · CWE (1)
- CWE-917 Improper Neutralization of Special Elements used in an Expression Language Statement weakness