GitHub Advisoryadvisory · PyPI

GHSA-p7xc-35m8-57pr FedMsg not properly completing message validation

HIGH Published 2018-07-13 Modified 2024-09-20 Official page ↗
Aliases
CVE-2017-1000001
Ecosystem
PyPI
Packages
FedMsg
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• PyPI FedMsg: < 0.18.2 → fixed in 0.18.2

Description

FedMsg 0.18.1 and older is vulnerable to a message validation flaw resulting in message validation not being enabled if configured to be on.

Related

Alias · CVE (1)

  • CVE-2017-1000001 FedMsg 0.18.1 and older is vulnerable to a message validation flaw resulting in message validation not being enabled if configured to be on. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References