GitHub Advisoryadvisory · npm

GHSA-p82g-2xpp-m5r3 Cross-Site Scripting in dojo

MEDIUM Published 2020-09-11 Modified 2021-09-28 Official page ↗
Aliases
CVE-2015-5654
Ecosystem
npm
Packages
dojo
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-08-31

Affected packages

• npm dojo: < 1.9.1 → fixed in 1.9.1

Description

Versions of `dojo` prior to 1.2.0 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize HTML code in user-controlled input, allowing attackers to execute arbitrary JavaScript in the victim's browser. Recommendation Upgrade to version 1.2.0 or later.

Related

Alias · CVE (1)

  • CVE-2015-5654 Cross-site scripting (XSS) vulnerability in Dojo Toolkit before 1.2 allows remote attackers to inject arbitrary web script or HTML via… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References