GitHub Advisoryadvisory · Packagist
GHSA-p8gw-x2p7-vc73 Magento Stored cross-site scripting in admin panel
MEDIUM
Official page ↗
- Aliases
- CVE-2019-7863
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-05-15
Affected packages
• Packagist magento/community-edition: >= 2.1, < 2.1.18 → fixed in 2.1.18
• Packagist magento/community-edition: >= 2.2, < 2.2.9 → fixed in 2.2.9
• Packagist magento/community-edition: >= 2.3, < 2.3.2 → fixed in 2.3.2
Description
A stored cross-site scripting vulnerability exists in the admin panel for Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This can be exploited by an authenticated user with access to products and categories.
Related
Alias · CVE (1)
- CVE-2019-7863 A stored cross-site scripting vulnerability exists in the admin panel for Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-7863 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-7863.yaml web
- https://github.com/magento/magento2 package
- https://web.archive.org/web/20201001022642/https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-23 web