GitHub Advisoryadvisory · Maven

GHSA-p9m8-27x8-rg87 Critical vulnerability found in cron-utils

CRITICAL Published 2021-11-15 Modified 2021-11-15 Official page ↗
Aliases
CVE-2021-41269
Ecosystem
Maven
Packages
com.cronutils:cron-utils
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2021-11-15

Affected packages

• Maven com.cronutils:cron-utils: < 9.1.6 → fixed in 9.1.6

Description

Impact A Template Injection was identified in cron-utils enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. Versions up to 9.1.2 are susceptible to this vulnerability. Please note, that only projects using the @Cron annotation to validate untrusted Cron expressions are affected. Patches The issue was patched and a new version was released. Please upgrade to version 9.1.6. Workarounds There are no known workarounds up to this moment. References A description of the issue is provided in issue 461 For more information If you have any questions or comments about this advisory: Open an issue in the cron-utils Github repository

Related

Alias · CVE (1)

  • CVE-2021-41269 cron-utils is a Java library to define, parse, validate, migrate crons as well as get human readable descriptions for them. vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References