GitHub Advisoryadvisory · Packagist

GHSA-pcrx-r49h-x2w5 Magento vulnerable to stored Cross-Site Scripting (XSS)

MEDIUM Published 2025-10-14 Modified 2025-10-21 Official page ↗
Aliases
CVE-2025-54266
Ecosystem
Packagist
Packages
magento/project-community-edition, magento/community-edition
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2025-10-21

Affected packages

• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet) • Packagist magento/community-edition: >= 2.4.9-alpha1, < 2.4.9-alpha3 → fixed in 2.4.9-alpha3 • Packagist magento/community-edition: >= 2.4.8-beta1, < 2.4.8-p3 → fixed in 2.4.8-p3 • Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p8 → fixed in 2.4.7-p8 • Packagist magento/community-edition: < 2.4.6-p13 → fixed in 2.4.6-p13 • Packagist magento/community-edition: 2.4.8 (no fix yet) • Packagist magento/community-edition: 2.4.7 (no fix yet) • Packagist magento/community-edition: 2.4.6 (no fix yet)

Description

Magento versions 2.4.9-alpha2, 2.4.8-p2, 2.4.7-p7, 2.4.6-p12, 2.4.5-p14, 2.4.4-p15 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a high-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. Exploitation of this issue requires user interaction in that a victim must browse to the page containing the vulnerable field. Scope is changed.

Related

Alias · CVE (1)

  • CVE-2025-54266 Adobe Commerce versions 2.4.9-alpha2, 2.4.8-p2, 2.4.7-p7, 2.4.6-p12, 2.4.5-p14, 2.4.4-p15 and earlier are affected by a stored Cross-Site… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References