GitHub Advisoryadvisory · PyPI
GHSA-pcwm-8jc3-qxvj Plone Denial of Service vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2011-4462
- Ecosystem
- PyPI
- Packages
- Plone
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2020-06-16
Affected packages
• PyPI Plone: < 4.1.4 → fixed in 4.1.4
Description
Plone 4.1.3 and earlier computes hash values for form parameters without restricting the ability to trigger hash collisions predictably, which allows remote attackers to cause a denial of service (CPU consumption) by sending many crafted parameters.
Related
Alias · CVE (1)
- CVE-2011-4462 Plone 4.1.3 and earlier computes hash values for form parameters without restricting the ability to trigger hash collisions predictably,… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2011-4462 advisory
- https://exchange.xforce.ibmcloud.com/vulnerabilities/72018 web
- https://github.com/advisories/GHSA-pcwm-8jc3-qxvj advisory
- https://github.com/plone/plone package
- https://github.com/pypa/advisory-database/tree/main/vulns/plone/PYSEC-2011-22.yaml web
- http://archives.neohapsis.com/archives/bugtraq/2011-12/0181.html web
- http://www.kb.cert.org/vuls/id/903934 web
- http://www.nruns.com/_downloads/advisory28122011.pdf web
- http://www.ocert.org/advisories/ocert-2011-003.html web