GitHub Advisoryadvisory · RubyGems
GHSA-pf6m-fxpq-fg8v Nokogiri implementation of libxslt lacks integer overflow checks
HIGH
Official page ↗
- Aliases
- CVE-2017-5029
- Ecosystem
- RubyGems
- Packages
- nokogiri
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-787
- Reviewed
- 2020-06-16
Affected packages
• RubyGems nokogiri: < 1.7.2 → fixed in 1.7.2
Description
The xsltAddTextString function in transform.c in libxslt 1.1.29, as used in Nokogiri prior to 1.7.2, lacked a check for integer overflow during a size calculation, which allowed a remote attacker to perform an out of bounds memory write via a crafted HTML page.
Related
Alias · CVE (1)
- CVE-2017-5029 The xsltAddTextString function in transform.c in libxslt 1.1.29, as used in Blink in Google Chrome prior to 57.0.2987.98 for Mac, Windows,… vulnerability
Weakness · CWE (1)
- CWE-787 Out-of-bounds Write weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-5029 advisory
- https://github.com/sparklemotion/nokogiri/issues/1634 web
- https://git.gnome.org/browse/libxslt/commit/?id=08ab2774b870de1c7b5a48693df75e8154addae5 web
- https://github.com/advisories/GHSA-pf6m-fxpq-fg8v advisory
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2017-5029.yml web
- https://github.com/sparklemotion/nokogiri package
- https://ubuntu.com/security/CVE-2017-5029 web
- https://ubuntu.com/security/notices/USN-3271-1 web