GitHub Advisoryadvisory · Packagist
GHSA-pf6w-3pfw-fxvw Magento SQL Injection vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2020-24400
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- Weaknesses
- CWE-89
- Reviewed
- 2024-01-11
Affected packages
• Packagist magento/community-edition: < 2.3.6 → fixed in 2.3.6
• Packagist magento/community-edition: >= 2.4.0, < 2.4.1 → fixed in 2.4.1
Description
Magento versions 2.4.0 and 2.3.5 (and earlier) are affected by an SQL Injection vulnerability that could lead to sensitive information disclosure. This vulnerability could be exploited by an authenticated user with permissions to the product listing page to read data from the database.
Related
Alias · CVE (1)
- CVE-2020-24400 Magento versions 2.4.0 and 2.3.5 (and earlier) are affected by an SQL Injection vulnerability that could lead to sensitive information… vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness