GitHub Advisoryadvisory · Maven

GHSA-pfc9-2cqg-9wq6 Reactor Netty HTTP Client Leaks Credentials On Protocol Downgrade Redirect

MEDIUM Published 2026-06-09 Modified 2026-07-29 Official page ↗
Aliases
CVE-2026-41715
Ecosystem
Maven
Packages
io.projectreactor.netty:reactor-netty
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-522
Reviewed
2026-07-29

Affected packages

• Maven io.projectreactor.netty:reactor-netty: >= 1.3.0, < 1.3.6 → fixed in 1.3.6 • Maven io.projectreactor.netty:reactor-netty: >= 1.2.0, < 1.2.18 → fixed in 1.2.18 • Maven io.projectreactor.netty:reactor-netty: >= 1.1.0, <= 1.1.31 (no fix yet) • Maven io.projectreactor.netty:reactor-netty: >= 1.0.0, <= 1.0.48 (no fix yet)

Description

In specific scenarios involving HTTP redirects from a secure to an insecure endpoint, the Reactor Netty HTTP client may leak credentials. In order for this to happen, the HTTP client must have been explicitly configured to follow redirects. Affected versions: Reactor Netty 1.0.0 through 1.0.51; 1.1.0 through 1.1.35; 1.2.0 through 1.2.17; 1.3.0 through 1.3.5.

Related

Alias · CVE (1)

  • CVE-2026-41715 In specific scenarios involving HTTP redirects from a secure to an insecure endpoint, the Reactor Netty HTTP client may leak credentials. vulnerability

Weakness · CWE (1)

  • CWE-522 Insufficiently Protected Credentials weakness

References