GitHub Advisoryadvisory · Packagist
GHSA-pfg4-p438-p874 Laravel Framework Deserialization Vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2019-9081
- Ecosystem
- Packagist
- Packages
- laravel/framework
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2023-07-19
Affected packages
• Packagist laravel/framework: >= 5.7.0, < 6.20.44 → fixed in 6.20.44
Description
The Illuminate component of Laravel Framework 5.7.x has a deserialization vulnerability that can lead to remote code execution if the content is controllable, related to the `__destruct` method of the PendingCommand class in `PendingCommand.php`.
Related
Alias · not in database (1)
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-9081 advisory
- https://github.com/Laworigin/Laworigin.github.io/blob/master/2019/02/21/laravelv5-7%E5%8F%8D%E5%BA%8F%E5%88%97%E5%8C%96rce/index.html web
- https://github.com/laravel/framework package
- https://github.com/laravel/framework/discussions/40184 web
- https://laworigin.github.io/2019/02/21/laravelv5-7%E5%8F%8D%E5%BA%8F%E5%88%97%E5%8C%96rce web