GitHub Advisoryadvisory · Packagist

GHSA-pfm2-mqwj-ggm5 MediaWiki makeCollapsible allows applying event handler to any CSS selector

MEDIUM Published 2022-05-24 Modified 2024-04-01 Official page ↗
Aliases
CVE-2020-10960
Ecosystem
Packagist
Packages
mediawiki/core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-116, CWE-74
Reviewed
2024-04-01

Affected packages

• Packagist mediawiki/core: >= 1.31.0, < 1.31.7 → fixed in 1.31.7 • Packagist mediawiki/core: >= 1.33.0, < 1.33.3 → fixed in 1.33.3 • Packagist mediawiki/core: >= 1.34.0, < 1.34.1 → fixed in 1.34.1

Description

In MediaWiki before 1.34.1, users can add various Cascading Style Sheets (CSS) classes (which can affect what content is shown or hidden in the user interface) to arbitrary DOM nodes via HTML content within a MediaWiki page. This occurs because jquery.makeCollapsible allows applying an event handler to any Cascading Style Sheets (CSS) selector. There is no known way to exploit this for cross-site scripting (XSS).

Related

Alias · CVE (1)

  • CVE-2020-10960 In MediaWiki before 1.34.1, users can add various Cascading Style Sheets (CSS) classes (which can affect what content is shown or hidden in… vulnerability

Weakness · CWE (2)

  • CWE-116 Improper Encoding or Escaping of Output weakness
  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness

References