GitHub Advisoryadvisory · RubyGems

GHSA-pfpr-3463-c6jh ruby-git has potential remote code execution vulnerability

HIGH Published 2023-01-09 Modified 2025-04-04 Official page ↗
Aliases
CVE-2022-46648
Ecosystem
RubyGems
Packages
git
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2023-01-09

Affected packages

• RubyGems git: >= 1.2.0, < 1.13.0 → fixed in 1.13.0

Description

The git gem, between versions 1.2.0 and 1.12.0, incorrectly parsed the output of the `git ls-files` command using `eval()` to unescape quoted file names. If a file name was added to the git repository contained special characters, such as `\n`, then the `git ls-files` command would print the file name in quotes and escape any special characters. If the `Git#ls_files` method encountered a quoted file name it would use `eval()` to unquote and unescape any special characters, leading to potential remote code execution. Version 1.13.0 of the git gem was released which correctly parses any quoted file names.

Related

Alias · CVE (1)

  • CVE-2022-46648 ruby-git versions prior to v1.13.0 allows a remote authenticated attacker to execute an arbitrary ruby code by having a user to load a… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References