GitHub Advisoryadvisory · PyPI
GHSA-pg7h-5qx3-wjr3 Pytorch use-after-free vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2024-31583
- Ecosystem
- PyPI
- Packages
- torch
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-416
- Reviewed
- 2024-07-25
Affected packages
• PyPI torch: < 2.2.0 → fixed in 2.2.0
Description
Pytorch before version v2.2.0 was discovered to contain a use-after-free vulnerability in torch/csrc/jit/mobile/interpreter.cpp.
Related
Alias · CVE (1)
- CVE-2024-31583 Pytorch before version v2.2.0 was discovered to contain a use-after-free vulnerability in torch/csrc/jit/mobile/interpreter.cpp. vulnerability
Weakness · CWE (1)
- CWE-416 Use After Free weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-31583 advisory
- https://github.com/pytorch/pytorch/commit/9c7071b0e324f9fb68ab881283d6b8d388a4bcd2 web
- https://gist.github.com/1047524396/43e19a41f2b36503a4a228c32cdbc176 web
- https://github.com/pypa/advisory-database/tree/main/vulns/torch/PYSEC-2024-251.yaml web
- https://github.com/pytorch/pytorch package
- https://github.com/pytorch/pytorch/blob/v2.1.2/torch/csrc/jit/mobile/interpreter.cpp#L132 web
- https://security.snyk.io/vuln/SNYK-PYTHON-TORCH-6619806 web