GitHub Advisoryadvisory · PyPI

GHSA-pg8m-4p8j-2p56 Apache Superset SQL Injection when template processing is enabled

HIGH Published 2022-05-24 Modified 2024-09-13 Official page ↗
Aliases
CVE-2021-41971
Ecosystem
PyPI
Packages
apache-superset
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2022-06-21

Affected packages

• PyPI apache-superset: < 1.3.1 → fixed in 1.3.1

Description

Apache Superset up to and including 1.3.0 when configured with ENABLE_TEMPLATE_PROCESSING on (disabled by default) allowed SQL injection when a malicious authenticated user sends an http request with a custom URL.

Related

Alias · CVE (1)

  • CVE-2021-41971 Apache Superset up to and including 1.3.0 when configured with ENABLE_TEMPLATE_PROCESSING on (disabled by default) allowed SQL injection… vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References