GitHub Advisoryadvisory · npm

GHSA-pg97-ww7h-5mjr XSS in dojox due to insufficient escape in dojox.xmpp.util.xmlEncode

MEDIUM Published 2020-02-13 Modified 2021-08-19 Official page ↗
Aliases
CVE-2019-10785
Ecosystem
npm
Packages
dojox
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-02-13

Affected packages

• npm dojox: < 1.11.9 → fixed in 1.11.9 • npm dojox: >= 1.12.0, < 1.12.7 → fixed in 1.12.7 • npm dojox: >= 1.13.0, < 1.13.6 → fixed in 1.13.6 • npm dojox: >= 1.14.0, < 1.14.5 → fixed in 1.14.5 • npm dojox: >= 1.15.0, < 1.15.2 → fixed in 1.15.2 • npm dojox: >= 1.16.0, < 1.16.1 → fixed in 1.16.1

Description

Impact _What kind of vulnerability is it? Who is impacted?_ Potential XSS vulnerability for users of `dojox/xmpp` and `dojox/dtl`. Patches _Has the problem been patched? What versions should users upgrade to?_ Yes, patches are available for the 1.11 through 1.16 versions. Users should upgrade to one of these versions of Dojo: • 1.16.1 • 1.15.2 • 1.14.5 • 1.13.6 • 1.12.7 • 1.11.9 Users of Dojo 1.10.x and earlier should review this change and determine if it impacts them, and backport the change as appropriate. Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ The change applied in https://github.com/dojo/dojox/pull/315 could get added separately as a patch. For more information If you have any questions or comments about this advisory: • Open an issue in dojo/dojox

Related

Alias · CVE (1)

  • CVE-2019-10785 dojox is vulnerable to Cross-site Scripting in all versions before version 1.16.1, 1.15.2, 1.14.5, 1.13.6, 1.12.7 and 1.11.9. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References