GitHub Advisoryadvisory · npm
GHSA-pg98-6v7f-2xfv sweetalert2 v9.17.4 and above contains hidden functionality
LOW
Official page ↗
- Ecosystem
- npm
- Packages
- sweetalert2
- Severity
- Low
- Weaknesses
- CWE-912
- Reviewed
- 2022-11-23
Affected packages
• npm sweetalert2: >= 9.17.4, < 11.22.4 → fixed in 11.22.4
Description
`sweetalert2` versions 9.17.4 and up until 10.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 9.0.0 - 9.17.3.
Workaround
Users who are unable to update to the fixed version (11.22.4) can use package versions 9.0.0-9.17.3, as they do not contain the hidden functionality.
Related
Weakness · CWE (1)
- CWE-912 Hidden Functionality weakness