GitHub Advisoryadvisory · Maven

GHSA-pgjc-gc7g-p2c6 Cloud Foundry UAA Privilege Escalation

HIGH Published 2022-05-13 Modified 2024-03-01 Official page ↗
Aliases
CVE-2017-4973
Ecosystem
Maven
Packages
org.cloudfoundry.identity:cloudfoundry-identity-server
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-269
Reviewed
2024-03-01

Affected packages

• Maven org.cloudfoundry.identity:cloudfoundry-identity-server: >= 2.0.0, < 2.7.4.14 → fixed in 2.7.4.14 • Maven org.cloudfoundry.identity:cloudfoundry-identity-server: >= 3.0.0, < 3.6.8 → fixed in 3.6.8 • Maven org.cloudfoundry.identity:cloudfoundry-identity-server: >= 3.7.0, < 3.9.10 → fixed in 3.9.10 • Maven org.cloudfoundry.identity:cloudfoundry-identity-server: >= 3.10.0, < 3.15.0 → fixed in 3.15.0

Description

An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v257; UAA release 2.x versions prior to v2.7.4.14, 3.6.x versions prior to v3.6.8, 3.9.x versions prior to v3.9.10, and other versions prior to v3.15.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.12, 24.x versions prior to v24.7, and other versions prior to v30. A vulnerability has been identified with the groups endpoint in UAA allowing users to elevate their privileges.

Related

Alias · CVE (1)

  • CVE-2017-4973 An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v257; UAA release 2.x versions prior to v2.7.4.14, 3.6.x… vulnerability

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References