GitHub Advisoryadvisory · RubyGems
GHSA-pgm4-439c-5jp6 Rails has a possible XSS vulnerability in its Action Pack debug exceptions
LOW
Official page ↗
- Aliases
- CVE-2026-33167
- Ecosystem
- RubyGems
- Packages
- actionpack
- Severity
- Low
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U
- Weaknesses
- CWE-79
- Reviewed
- 2026-03-23
Affected packages
• RubyGems actionpack: >= 8.1.0, < 8.1.2.1 → fixed in 8.1.2.1
Description
Impact
The debug exceptions page does not properly escape exception messages. A carefully crafted exception message could inject arbitrary HTML and JavaScript into the page, leading to XSS. This affects applications with detailed exception pages enabled (`config.consider_all_requests_local = true`), which is the default in development.
Releases
The fixed releases are available at the normal locations.
Credit
This issue was responsibly reported by Hackerone researcher fbettag.
Related
Alias · CVE (1)
- CVE-2026-33167 Action Pack is a Rubygem for building web applications on the Rails framework. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/rails/rails/security/advisories/GHSA-pgm4-439c-5jp6 web
- https://nvd.nist.gov/vuln/detail/CVE-2026-33167 advisory
- https://github.com/rails/rails/commit/6752711c8c31d79ba50d13af6a6698a3b85415e0 web
- https://github.com/rails/rails package
- https://github.com/rails/rails/releases/tag/v8.1.2.1 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2026-33167.yml web