GitHub Advisoryadvisory · Packagist
GHSA-pgm5-cr62-prxq Moodle Arbitrary file read when importing lesson questions
HIGH
Official page ↗
- Aliases
- CVE-2022-35650
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.9, < 3.9.15 → fixed in 3.9.15
• Packagist moodle/moodle: >= 3.11, < 3.11.8 → fixed in 3.11.8
• Packagist moodle/moodle: >= 4.0, < 4.0.2 → fixed in 4.0.2
Description
The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.
Related
Alias · CVE (1)
- CVE-2022-35650 The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-35650 advisory
- https://bugzilla.redhat.com/show_bug.cgi?id=2106274 web
- https://github.com/moodle/moodle package
- https://lists.fedoraproject.org/archives/list/[email protected]/message/6MOKYVRNFNAODP2XSMGJ5CRDUZCZKAR3 web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/MTKUSFPSYFINSQFSOHDQIDVE6FWBEU6V web
- https://moodle.org/mod/forum/discuss.php?d=436457 web
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-72029 web