GitHub Advisoryadvisory · Maven

GHSA-pgq7-jcj5-xx6h Apache Druid before 0.23.0 vulnerable to clickjacking

MEDIUM Published 2022-07-08 Modified 2022-07-19 Official page ↗
Aliases
CVE-2022-28889
Ecosystem
Maven
Packages
org.apache.druid:druid
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Weaknesses
CWE-1021
Reviewed
2022-07-08

Affected packages

• Maven org.apache.druid:druid: < 0.23.0 → fixed in 0.23.0

Description

In Apache Druid 0.22.1 and earlier, the server did not set appropriate headers to prevent clickjacking. Druid 0.23.0 and later prevent clickjacking using the Content-Security-Policy header.

Related

Alias · CVE (1)

  • CVE-2022-28889 In Apache Druid 0.22.1 and earlier, the server did not set appropriate headers to prevent clickjacking. vulnerability

Weakness · CWE (1)

  • CWE-1021 Improper Restriction of Rendered UI Layers or Frames weakness

References