GitHub Advisoryadvisory · Packagist
GHSA-phhm-6pgm-mxw9 MODX Revolution blind SQL injection
HIGH
Official page ↗
- Aliases
- CVE-2017-1000067
- Ecosystem
- Packagist
- Packages
- modx/revolution
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89
- Reviewed
- 2024-04-23
Affected packages
• Packagist modx/revolution: >= 2.0.0, < 2.6.0 → fixed in 2.6.0
Description
MODX Revolution version 2.x - 2.5.6 is vulnerable to blind SQL injection caused by improper sanitization by the escape method resulting in authenticated user accessing database and possibly escalating privileges.
Related
Alias · CVE (1)
- CVE-2017-1000067 MODX Revolution version 2.x - 2.5.6 is vulnerable to blind SQL injection caused by improper sanitization by the escape method resulting in… vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness