GitHub Advisoryadvisory · Packagist

GHSA-phrq-v4q2-hmq6 Sabberworm PHP CSS Parser Code injection vulnerability in allSelectors()

CRITICAL Published 2022-03-26 Modified 2025-11-03 Official page ↗
Aliases
CVE-2020-13756
Ecosystem
Packagist
Packages
sabberworm/php-css-parser
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20, CWE-94
Reviewed
2022-03-26

Affected packages

• Packagist sabberworm/php-css-parser: >= 8.3.0, < 8.3.1 → fixed in 8.3.1 • Packagist sabberworm/php-css-parser: >= 8.2.0, < 8.2.1 → fixed in 8.2.1 • Packagist sabberworm/php-css-parser: >= 8.1.0, < 8.1.1 → fixed in 8.1.1 • Packagist sabberworm/php-css-parser: >= 8.0.0, < 8.0.1 → fixed in 8.0.1 • Packagist sabberworm/php-css-parser: >= 7.0.0, < 7.0.4 → fixed in 7.0.4 • Packagist sabberworm/php-css-parser: >= 6.0.0, < 6.0.2 → fixed in 6.0.2 • Packagist sabberworm/php-css-parser: >= 5.2.0, < 5.2.1 → fixed in 5.2.1 • Packagist sabberworm/php-css-parser: >= 5.1.0, < 5.1.3 → fixed in 5.1.3 • Packagist sabberworm/php-css-parser: >= 5.0.0, < 5.0.9 → fixed in 5.0.9 • Packagist sabberworm/php-css-parser: >= 4.0.0, < 4.0.1 → fixed in 4.0.1 • Packagist sabberworm/php-css-parser: >= 3.0.0, < 3.0.1 → fixed in 3.0.1 • Packagist sabberworm/php-css-parser: >= 2.0.0, < 2.0.1 → fixed in 2.0.1 • Packagist sabberworm/php-css-parser: >= 1.0.0, < 1.0.1 → fixed in 1.0.1

Description

Sabberworm PHP CSS Parser before 8.3.1 calls eval on uncontrolled data, possibly leading to remote code execution if the function allSelectors() or getSelectorsBySpecificity() is called with input from an attacker.

Related

Alias · CVE (1)

  • CVE-2020-13756 Sabberworm PHP CSS Parser before 8.3.1 calls eval on uncontrolled data, possibly leading to remote code execution if the function… vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-94 Improper Control of Generation of Code weakness

References