GitHub Advisoryadvisory · Maven
GHSA-pj45-8vhc-mh2f Jenkins Swarm Plugin Client vulnerable to man-in-the-middle attacks
MEDIUM
Official page ↗
- Aliases
- CVE-2017-1000402
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:swarm-client, org.jvnet.hudson.plugins:swarm-plugin
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2022-11-22
Affected packages
• Maven org.jenkins-ci.plugins:swarm-client: < 3.5 → fixed in 3.5
• Maven org.jvnet.hudson.plugins:swarm-plugin: <= 1.5 (no fix yet)
Description
Jenkins Swarm Plugin Client 3.4 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks.
Related
Alias · CVE (1)
- CVE-2017-1000402 Jenkins Swarm Plugin Client 3.4 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness