GitHub Advisoryadvisory · RubyGems

GHSA-pj73-v5mw-pm9j Possible XSS Security Vulnerability in SafeBuffer#bytesplice

MEDIUM Published 2023-03-15 Modified 2025-01-10 Official page ↗
Aliases
CVE-2023-28120
Ecosystem
RubyGems
Packages
activesupport
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-03-15

Affected packages

• RubyGems activesupport: >= 7.0.0, < 7.0.4.3 → fixed in 7.0.4.3 • RubyGems activesupport: < 6.1.7.3 → fixed in 6.1.7.3

Description

There is a vulnerability in ActiveSupport if the new bytesplice method is called on a SafeBuffer with untrusted user input. This vulnerability has been assigned the CVE identifier CVE-2023-28120. Versions Affected: All. Not affected: None Fixed Versions: 7.0.4.3, 6.1.7.3 Impact ActiveSupport uses the SafeBuffer string subclass to tag strings as html_safe after they have been sanitized. When these strings are mutated, the tag is should be removed to mark them as no longer being html_safe. Ruby 3.2 introduced a new bytesplice method which ActiveSupport did not yet understand to be a mutation. Users on older versions of Ruby are likely unaffected. All users running an affected release and using bytesplice should either upgrade or use one of the workarounds immediately. Workarounds Avoid calling bytesplice on a SafeBuffer (html_safe) string with untrusted user input.

Related

Alias · CVE (1)

  • CVE-2023-28120 There is a vulnerability in ActiveSupport if the new bytesplice method is called on a SafeBuffer with untrusted user input. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References