GitHub Advisoryadvisory · npm
GHSA-pj7x-6wpf-pgvp Payload: SQL injection in SQLite/Postgres
HIGH
Official page ↗
- Aliases
- CVE-2026-105856
- Ecosystem
- npm
- Packages
- @payloadcms/db-sqlite, @payloadcms/db-d1-sqlite, @payloadcms/db-postgres, @payloadcms/db-vercel-postgres
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- Weaknesses
- CWE-89
- Reviewed
- 2026-10-07
Affected packages
• npm @payloadcms/db-sqlite: >= 3.0.0, < 3.90.0 → fixed in 3.90.0
• npm @payloadcms/db-d1-sqlite: >= 3.0.0, < 3.90.0 → fixed in 3.90.0
• npm @payloadcms/db-postgres: >= 3.0.0, < 3.73.0 → fixed in 3.73.0
• npm @payloadcms/db-vercel-postgres: >= 3.0.0, < 3.73.0 → fixed in 3.73.0
• npm @payloadcms/db-sqlite: >= 4.0.0-canary.0, < 4.0.0-canary.34 → fixed in 4.0.0-canary.34
• npm @payloadcms/db-d1-sqlite: >= 4.0.0-canary.0, < 4.0.0-canary.34 → fixed in 4.0.0-canary.34
Description
Impact
An attacker who has read plus create or update access to a collection can submit a request that includes a SQL injection targeting a specific field path shape and operators in Payload's SQLite and Postgres.
You are affected if:
• You use `@payloadcms/db-sqlite` or `@payloadcms/db-d1-sqlite`.
• You use `@payloadcms/db-postgres` or `@payloadcms/db-vercel-postgres` `= 3.90.0` or `>= 4.0.0-canary.34`.
Related
Alias · CVE (1)
- CVE-2026-105856 Payload is a free and open source headless content management system. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://github.com/payloadcms/payload/security/advisories/GHSA-pj7x-6wpf-pgvp web
- https://nvd.nist.gov/vuln/detail/CVE-2026-105856 advisory
- https://github.com/payloadcms/payload/commit/03b78c7e0901d19c67f07bdf6396a276010adbcc web
- https://github.com/payloadcms/payload package
- https://github.com/payloadcms/payload/releases/tag/v3.90.0 web