GitHub Advisoryadvisory · Packagist
GHSA-pjj4-jjgc-h3r8 Authenticated remote code execution
MEDIUM
Official page ↗
- Ecosystem
- Packagist
- Packages
- shopware/platform
- Severity
- Moderate
- Weaknesses
- CWE-74
- Reviewed
- 2021-03-12
Affected packages
• Packagist shopware/platform: < 6.3.5.2 → fixed in 6.3.5.2
Description
Impact
Authenticated remote code execution using plugin manager without ACL permissions.
Patches
We recommend to update to the current version 6.3.5.2. You can get the update to 6.3.5.2 regularly via the Auto-Updater or directly via the download overview.
https://www.shopware.com/en/download/#shopware-6
Workarounds
For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659
For more information
https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-03-2021
Related
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness