GitHub Advisoryadvisory · npm
GHSA-pjwm-rvh2-c87w Embedded malware in ua-parser-js
HIGH
Official page ↗
- Aliases
- CVE-2021-4229
- Ecosystem
- npm
- Packages
- ua-parser-js
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-506, CWE-912
- Reviewed
- 2021-10-22
Affected packages
• npm ua-parser-js: >= 0.7.29, < 0.7.30 → fixed in 0.7.30
• npm ua-parser-js: >= 0.8.0, < 0.8.1 → fixed in 0.8.1
• npm ua-parser-js: >= 1.0.0, < 1.0.1 → fixed in 1.0.1
Description
The npm package `ua-parser-js` had three versions published with malicious code. Users of affected versions (0.7.29, 0.8.0, 1.0.0) should upgrade as soon as possible and check their systems for suspicious activity. See this issue for details as they unfold.
Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer. The package should be removed, but as full control of the computer may have been given to an outside entity, there is no guarantee that removing the package will remove all malicious software resulting from installing it.
Related
Alias · CVE (1)
- CVE-2021-4229 A vulnerability was found in ua-parser-js 0.7.29/0.8.0/1.0.0. vulnerability