GitHub Advisoryadvisory · npm

GHSA-pm35-fqvh-cq5g n8n: Legacy Expression Evaluator Sanitizer Bypass Leads to Authenticated Code Execution

HIGH Published 2026-07-22 Modified 2026-07-22 Official page ↗
Aliases
CVE-2026-65591
Ecosystem
npm
Packages
n8n
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:L
Weaknesses
CWE-917
Reviewed
2026-07-22

Affected packages

• npm n8n: < 1.123.64 → fixed in 1.123.64 • npm n8n: >= 2.30.0, < 2.30.1 → fixed in 2.30.1 • npm n8n: >= 2.0.0-rc.0, < 2.29.8 → fixed in 2.29.8

Description

Impact The legacy expression evaluator's computed-member sanitizer can be bypassed by an authenticated user with workflow create or modify permissions. Successful exploitation grants the attacker host-level code execution as the n8n process. The legacy expression engine is the default engine in affected versions. Patches The issue has been fixed in n8n versions 1.123.64, 2.29.8, and 2.30.1. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: • Restrict n8n instance access to fully trusted users only. • Switch to the non-legacy expression engine by setting `N8N_EXPRESSION_ENGINE=vm`. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Related

Alias · CVE (1)

  • CVE-2026-65591 n8n contains a sanitizer bypass vulnerability in the legacy expression evaluator's computed-member handler. vulnerability

Weakness · CWE (1)

  • CWE-917 Improper Neutralization of Special Elements used in an Expression Language Statement weakness

References