GitHub Advisoryadvisory · PyPI

GHSA-pm48-cvv2-29q5 Ansible Uses Plugins That Disclose Credentials

HIGH Published 2022-05-24 Modified 2024-09-09 Official page ↗
Aliases
CVE-2019-14846
Ecosystem
PyPI
Packages
ansible
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-117, CWE-532
Reviewed
2023-07-17

Affected packages

• PyPI ansible: < 2.6.20 → fixed in 2.6.20 • PyPI ansible: >= 2.7.0a1, < 2.7.14 → fixed in 2.7.14 • PyPI ansible: >= 2.8.0a1, < 2.8.6 → fixed in 2.8.6

Description

Ansible, all ansible_engine-2.x versions and ansible_engine-3.x up to ansible_engine-3.5, was logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.

Related

Alias · CVE (1)

  • CVE-2019-14846 In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG… vulnerability

Weakness · CWE (2)

  • CWE-117 Improper Output Neutralization for Logs weakness
  • CWE-532 Insertion of Sensitive Information into Log File weakness

References