GitHub Advisoryadvisory · RubyGems

GHSA-pm55-qfxr-h247 OmniAuth's `lib/omniauth/failure_endpoint.rb` does not escape `message_key` value

CRITICAL Published 2022-08-19 Modified 2022-08-31 Official page ↗
Aliases
CVE-2020-36599
Ecosystem
RubyGems
Packages
omniauth
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-116
Reviewed
2022-08-31

Affected packages

• RubyGems omniauth: < 1.9.2 → fixed in 1.9.2 • RubyGems omniauth: >= 2.0.0.pre.rc1, < 2.0.0 → fixed in 2.0.0

Description

lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.

Related

Alias · CVE (1)

  • CVE-2020-36599 lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value. vulnerability

Weakness · CWE (1)

  • CWE-116 Improper Encoding or Escaping of Output weakness

References