GitHub Advisoryadvisory · Packagist
GHSA-pm77-c4q7-3fwj Improper Certificate Validation in Heartland & Global Payments PHP SDK
MEDIUM
Official page ↗
- Aliases
- CVE-2019-20455
- Ecosystem
- Packagist
- Packages
- globalpayments/php-sdk
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-295
- Reviewed
- 2021-10-08
Affected packages
• Packagist globalpayments/php-sdk: < 2.0.0 → fixed in 2.0.0
Description
Gateways/Gateway.php in Heartland & Global Payments PHP SDK before 2.0.0 does not enforce SSL certificate validations.
Related
Alias · CVE (1)
- CVE-2019-20455 Gateways/Gateway.php in Heartland & Global Payments PHP SDK before 2.0.0 does not enforce SSL certificate validations. vulnerability
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-20455 advisory
- https://github.com/globalpayments/php-sdk/pull/8 web
- https://github.com/globalpayments/php-sdk/pull/8/commits/c86e18f28c5eba0d6ede7d557756d978ea83d3c9 web
- https://github.com/globalpayments/php-sdk package
- https://github.com/globalpayments/php-sdk/compare/1.3.3...2.0.0 web
- https://github.com/globalpayments/php-sdk/releases/tag/2.0.0 web
- https://winterdragon.ca/global-payments-vulnerability web