GitHub Advisoryadvisory · npm

GHSA-pmqw-72cg-wx85 n8n: Credential Exfiltration via Permission Bypass

HIGH Published 2026-06-16 Modified 2026-07-08 Official page ↗
Aliases
CVE-2026-54307
Ecosystem
npm
Packages
n8n
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
Weaknesses
CWE-863
Reviewed
2026-06-16

Affected packages

• npm n8n: < 1.123.55 → fixed in 1.123.55 • npm n8n: >= 2.26.0, < 2.26.2 → fixed in 2.26.2 • npm n8n: >= 2.0.0-rc.0, < 2.25.7 → fixed in 2.25.7

Description

Impact A member-level user with editor access to a shared workflow could reference credentials they do not own via specific public API endpoints. Credential ownership checks were only enforced partially leading to cross-user credential access. This issue affects instances where workflow sharing is enabled and at least one workflow has been shared with a member-level user as an Editor. Patches The issue has been fixed in n8n versions 1.123.55, 2.25.7, and 2.26.2. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: • Restrict workflow sharing to fully trusted users only. • Audit shared workflows for unexpected credential references or recent modifications. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures. --- n8n has adopted CVSS 4.0 as primary score for all security advisories. CVSS 3.1 vector strings are provided for backwards compatibility. CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N

Related

Alias · CVE (1)

  • CVE-2026-54307 n8n is an open source workflow automation platform. vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References