GitHub Advisoryadvisory · Packagist
GHSA-pp7v-wxx9-hm6r Thelia BackOffice default template vulnerable to Cross-site Scripting
MEDIUM
Official page ↗
- Ecosystem
- Packagist
- Packages
- thelia/backoffice-default-template
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-05-30
Affected packages
• Packagist thelia/backoffice-default-template: >= 2.1.0, < 2.1.2 → fixed in 2.1.2
Description
The BackOffice of Thelia (`error.html` template) has a cross-site scripting vulnerability in version 2.1.0 and 2.1.1 but not version 2.0.X. Version 2.1.2 contains a patch for the issue.
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/thelia-templates/back/commit/592612899057addc2613ccddf172024588277d2d web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/thelia/backoffice-default-template/2015-02-24-1.yaml web
- https://github.com/thelia-templates/back package
- https://thelia.net/version-2-1-2-with-security-fix web
- https://web.archive.org/web/20160406004324/http://thelia.net/version-2-1-2-with-security-fix web