GitHub Advisoryadvisory · PyPI
GHSA-pp84-v3mw-gg4w Taipy 3.1.1 affected by CVEs on flask-core and pymongo
HIGH
Official page ↗
- Ecosystem
- PyPI
- Packages
- taipy
- Severity
- High
- Reviewed
- 2024-08-27
Affected packages
• PyPI taipy: < 4.0.0 → fixed in 4.0.0
Description
Summary
Indirect CVEs affect Taipy 3.1.1
Details
Taipy 3.1.1 is affected by two existing CVEs:
CVE-2024-1681 affects flask-core =3.1.2
and on major releases: >=4.0.0
Impact
pre-commit breaks when using dependency Taipy 3.1.1
References
- https://github.com/Avaiga/taipy/security/advisories/GHSA-pp84-v3mw-gg4w web
- https://nvd.nist.gov/vuln/detail/CVE-2024-1681 advisory
- https://nvd.nist.gov/vuln/detail/CVE-2024-5629 advisory
- https://github.com/Avaiga/taipy package
- https://github.com/advisories/GHSA-84pr-m4jr-85g5 advisory
- https://github.com/advisories/GHSA-m87m-mmvp-v9qm advisory