GitHub Advisoryadvisory · Maven
GHSA-pprq-4488-wgqx Insecure transport protocol in Gradle
MEDIUM
Official page ↗
- Aliases
- CVE-2019-11065
- Ecosystem
- Maven
- Packages
- org.gradle:gradle-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-319
- Reviewed
- 2022-11-01
Affected packages
• Maven org.gradle:gradle-core: >= 1.4, < 5.4.0 → fixed in 5.4.0
Description
Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.
Related
Alias · CVE (1)
- CVE-2019-11065 Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle… vulnerability
Weakness · CWE (1)
- CWE-319 Cleartext Transmission of Sensitive Information weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-11065 advisory
- https://github.com/gradle/gradle/pull/8927 web
- https://github.com/gradle/gradle package
- https://lists.fedoraproject.org/archives/list/[email protected]/message/WVXOXNLAYRGPKAZV63PYNV3HF27JW2MW web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/Y43P7SVDJOG6OUDVFR4ZIDITZLNHPGTO web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/YQ5CGOV5QVQCSPGE3WRZDKUGIXLHSZDR web