GitHub Advisoryadvisory · npm
GHSA-pq37-4c4g-v38c Cross-site Scripting in vditor
MEDIUM
Official page ↗
- Aliases
- CVE-2022-0341
- Ecosystem
- npm
- Packages
- vditor
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-03-23
Affected packages
• npm vditor: < 3.8.11 → fixed in 3.8.11
Description
vditor prior to version 3.8.11 is vulnerable to cross-site scripting.
Related
Alias · CVE (1)
- CVE-2022-0341 Cross-site Scripting (XSS) - Stored in GitHub repository vanessa219/vditor prior to 3.8.12. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-0341 advisory
- https://github.com/Vanessa219/vditor/issues/1102 web
- https://github.com/vanessa219/vditor/commit/219f8a9e272aba3cbc0096a82cac776532dbb9e5 web
- https://github.com/vanessa219/vditor package
- https://huntr.dev/bounties/fa546b57-bc15-4705-824e-9474b616f628 web