GitHub Advisoryadvisory · Maven
GHSA-pqg3-xfx2-fmqp Cross site scripting vulnerability in update-center2
MEDIUM
Official page ↗
- Aliases
- CVE-2023-27905
- Ecosystem
- Maven
- Packages
- org.jenkins-ci:update-center2
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-03-16
Affected packages
• Maven org.jenkins-ci:update-center2: >= 3.13, < 3.15 → fixed in 3.15
Description
Jenkins update-center2 3.13 and 3.14 renders the required Jenkins core version on plugin download index pages without sanitization, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide a plugin for hosting.
Related
Alias · CVE (1)
- CVE-2023-27905 Jenkins update-center2 3.13 and 3.14 renders the required Jenkins core version on plugin download index pages without sanitization,… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness