GitHub Advisoryadvisory · Packagist

GHSA-pqv4-xgqh-j8vh Drupal sensitive information disclosure

MEDIUM Published 2022-05-17 Modified 2024-04-23 Official page ↗
Aliases
CVE-2016-3170
Ecosystem
Packagist
Packages
drupal/core, drupal/drupal
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-200
Reviewed
2024-04-23

Affected packages

• Packagist drupal/core: >= 7.0, < 7.43 → fixed in 7.43 • Packagist drupal/core: >= 8.0, < 8.0.4 → fixed in 8.0.4 • Packagist drupal/drupal: >= 8.0, < 8.0.4 → fixed in 8.0.4 • Packagist drupal/drupal: >= 7.0, < 7.43 → fixed in 7.43

Description

The "have you forgotten your password" links in the User module in Drupal 7.x before 7.43 and 8.x before 8.0.4 allow remote attackers to obtain sensitive username information by leveraging a configuration that permits using an email address to login and a module that permits logging in.

Related

Alias · CVE (1)

  • CVE-2016-3170 The "have you forgotten your password" links in the User module in Drupal 7.x before 7.43 and 8.x before 8.0.4 allow remote attackers to… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References