GitHub Advisoryadvisory · npm

GHSA-pr22-p9rp-2cqv Ghost: Cross-Site Scripting in Feature Image Captions

MEDIUM Published 2026-08-05 Modified 2026-08-05 Official page ↗
Aliases
CVE-2026-70596
Ecosystem
npm
Packages
ghost
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
Weaknesses
CWE-79
Reviewed
2026-08-05

Affected packages

• npm ghost: >= 4.9.0, < 6.54.1 → fixed in 6.54.1

Description

Impact An input validation issue allowed any staff user to create a post with content that could be used to hijack another staff user's Ghost Admin session resulting in privilege escalation. Vulnerable versions This vulnerability is present in Ghost from v4.9.0 up to v6.54.0. Patches v6.54.1 contains a fix for this issue. How to update For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here. References Ghost thanks Versa for disclosing this vulnerability responsibly. For more information If you have any questions or comments about this advisory, email Ghost at [email protected].

Related

Alias · CVE (1)

  • CVE-2026-70596 Ghost is a Node.js content management system. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References